Why the latest GPS Navigation 2 update is not compatible with the iPhone 3G anymore

Since we published our 4.3 Update for GPS Navigation 2, our 3G-users – those that updated – have had some issues with the app and are wondering what the problem is. Here are the circumstances:

With iOS 6 and the latest “SDK” (Software Developer Kit), Apple has removed the possibility to develop iPhone 3G-compatible apps. That means that all apps, actually, which are using the new SDK, are not working on the iPhone 3G anymore. We understand that this is very annoying for people owning such a device. Unfortunately, though, at this time, we’re unable to change this.

What’s even more confusing is that those apps are still shown in the App Store – also on the iPhone 3G. An error occurs only when you want to download the app. That’s when you get a fault message. Those who have already installed GPS Nav 2 also get the update notification in the App Store—even though the update is not compatible with their device. In this case, you should actually get an error message as well, when trying to download the update. Then you can still use the “old” version on your iPhone though.

But we also got messages where the update obviously could have been installed without problems. Only then, if you want to open the app and use it, it crashes. As it’s not possible to cancel the update, those users are quite upset. They want to have the “old” version back, which had worked perfectly on their device!

In this case we have a tip for you: While we can’t offer the old version on iTunes next to the latest one, if you still have it in your iTunes-backup on your computer, you can of course connect your iPhone with the computer and get it back on your device.